JUNOS subscriber management Logs to collect

These are the logs to collect for subscriber managemet problems before contacting Juniper's support. You will need to decide on which ones are relevant to you setup and enable them. An important thing to confirm is that there is enough disk space on the routing engines. Some of the traceoptions might impact performance based on the setup, so it's advisable to disable them after collecting the logs.

General
request support information | save rsi-1
set system syslog archive size 100m files 25
Autoconfiguration Daemon (autoconfd)
set system auto-configuration traceoptions file filename
set system auto-configuration traceoptions file filename size 500m files 5
PPP Daemon
set protocols ppp-service traceoptions file filename size 500 files 5
set protocols ppp-service traceoptions level all
set protocols ppp-service traceoptions flag all
JPPP Daemon (jpppd)
set protocols ppp traceoptions file filename size 500m files 5
set protocols ppp traceoptions level all
set protocols ppp traceoptions flag all
set protocols ppp monitor-session all
set interfaces pp0 traceoptions flag all
PPPoE Daemon (pppoed)
set protocols pppoe traceoptions file filename size 500m files 5
set protocols pppoe traceoptions level all
set protocols pppoe traceoptions flag all
Demux interfaces
set demux traceoptions file filename size 500m files 5
set demux traceoptions level all
set demux traceoptions flag all
JDHCP Daemon (jdhcpd)
set system processes dhcp-service traceoptions file filename
set system processes dhcp-service traceoptions file size 500m
set system processes dhcp-service traceoptions file files 5
set system processes dhcp-service traceoptions flag all
COS Daemon (COSD)
set class-of-service traceoptions file filename
set class-of-service traceoptions file size 500m
set class-of-service traceoptions flag all
set class-of-service traceoptions file files 5
RP Daemon (RPD)
set routing-options traceoptions file filename
set routing-options traceoptions file size 500m
set routing-options traceoptions flag all
set routing-options traceoptions file files 5
Interfaces
set interfaces traceoptions file filename
set interfaces traceoptions file size 500m
set interfaces traceoptions flag all
set interfaces traceoptions file files 5
General Authenication Service Daemon (Authd)
set system processes general-authentication-service traceoptions file filename
set system processes general-authentication-service traceoptions file size 500m
set system processes general-authentication-service traceoptions flag all
set system processes general-authentication-service traceoptions file files 5